Download data base

I have registered consumption with the openZmeter. I would like
download this year’s entire energy database with a
3-second resolution. Is there a way to do it? Since the time scale of one year does not allow such high resolution, I cannot do it from the web environment.


The right way is to download the data directly from PostgreSQL database. You can do it via ssh and accessing the database (copy to CSV or whatever) or using any SQL compatible manager like DBeaver.

Method 1: ssh way

  • ssh root@ozm_ip
  • psql --user postgres
  • \c openzmeter
  • \copy 'analyzer_serial'.aggreg_3s to 'filename.csv' csv header where 'analyzer_serial' is the serial number of your ozm (something like 630033002115D49XXXXXXX) that you will find in the config web (magnifying glass on the top left)

Method 2: DBeaver way

  • open DBeaver
  • create new PostgreSQL tunneled ssh connection to your ozm with:
    host: localhost
    Database: openzmeter
    user: postgres
    Network Setting – SSH Tunnel
    Host/IP: 'ozm_ip'
    Port: 22
    User Name: root
  • Navigate to your ozm_serial Schema and right click on the appropiate table, then export.

Using method 1, I am missing the password to make SSH connection.

Using method 2, I think the problem is similar. When testing connection with DBeaver it gives me the following error:
Can’t initialize tunnel
Cannot establish tunnel
Cannot establish tunnel
SSH_MSG_DISCONNECT: 2 Too many authentication failures
SSH_MSG_DISCONNECT: 2 Too many authentication failures

there is no ssh password!!

With method 1:
In screenshot 1, when sshing in linux to the ip of the openzmeter it asks me for a password.
In screen 2, pressing enter gives an error. Also try admin and 12345 and nothing

With method 2:
In screenshot 3, general configuration of the postgreSQL.
On screen 4, ssh configuration without password
In screenshot 5, the error where there appears to be an authentication failure
In screenshot 6, it clearly asks for a password and as I leave it empty it gives the same error as in screenshot 5.

I do not understand why it does give me login problems.
Regards,6 5

2 1

I send you a PM. Basically, you have an older version of the software.

Thank you very much, problem solved. It is very interesting to have access to complete tables for data analysis.